The League of Extraordinary Packages

Our Packages:

Presented by The League of Extraordinary Packages

Getting Started


Upgrading Guide

This is the documentation for the upcoming version 4.0. This is a work in progress.

Upgrading from 3.x to 4.x

League\Period 4.0 is a new major version that comes with backward compatibility breaks.

This guide will help you migrate from a 3.x version to 4.0. It will only explain backward compatibility breaks, it will not present the new features (read the documentation for that).


If you are using composer then you should update the require section of your composer.json file.

composer require league/period:^4.0

This will edit (or create) your composer.json file.

PHP version requirement

League\Period 4.0 requires a PHP version greater or equal than 7.1.0 (was previously 5.5.9).

The library is not tested on HHVM